Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 24 Hours Last 24 Hours Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Articles Articles
Filter by: Last 7 Days Clear All
  • 5thscaleracer's Avatar
    Yesterday, 10:15 PM
    Other way around if it bogs itís lean. The car will feel good even with 9.0:1 afr. A little slow getting up to redline but it will get there. ...
    68 replies | 11598 view(s)
  • 3f05q's Avatar
    Yesterday, 07:40 PM
    3f05q replied to a thread 2.3-16 Project in Member's Rides
    Plug: Top of #1: Appx 150 miles on these parts.... And likely a little wet since I ran it for 10 seconds to pull into the garage.
    68 replies | 11598 view(s)
  • SpartanV's Avatar
    Yesterday, 02:14 PM
    SpartanV replied to a thread 2.3-16 Project in Member's Rides
    Or lean
    68 replies | 11598 view(s)
  • glo86's Avatar
    Yesterday, 01:33 PM
    glo86 replied to a thread 2.3-16 Project in Member's Rides
    If it's bogs down during WOT than it could be running too rich.
    68 replies | 11598 view(s)
  • 3f05q's Avatar
    07-21-2019, 03:27 PM
    3f05q replied to a thread 2.3-16 Project in Member's Rides
    Crap... Not running great. Took it to Radwood. On the way back I started having a problem that seems common, but every thread I find on the subject...
    68 replies | 11598 view(s)
  • 3f05q's Avatar
    07-19-2019, 12:44 PM
    3f05q replied to a thread 2.3-16 Project in Member's Rides
    Little update. I've put about 50 miles on the rebuild so far. Running great! Thanks to you lot. The details have been invaluable. Hoping to take it...
    68 replies | 11598 view(s)
No More Results